Alpha-testing phase for YunoHost on Debian Stretch



I tested the case #1 on a dedicated server and i have the following error during the post installation step :

Error: Script execution failed: /usr/share/yunohost/hooks/conf_regen/43-dnsmasq

The service dnsmasq is not able to restart because :

dnsmasq[31589]: dnsmasq: failed to create listening socket for port 53: Address already in use

This port is used by named, which seems doing the same thing than dnsmasq. I don’t know which one is the most important (or maybe both are ?) but Yunohost works fine even with this error.

Uh well they dont exactly fulfill the same job. “Named” is actually bind9 - though I wouldnt be able to tell exactly about the exact jobs they fulfill :stuck_out_tongue:

Anyway, this should have been spotted by a piece of code in the install script here : but apparently it didn’t… (Somebody a few days also reported a similar issue for apache)

If you didnt touch your setup since then, can you try getting the output of this command ?

dpkg --get-selections | grep -v deinstall | grep 'bind9'

Also, thanks for the feedback ! :heart:

Here is the output :

bind9 install
bind9-host install
bind9utils install
libbind9-140:amd64 install

I think the function check_assertions works : the dedicated server is a fresh installation so the bind9 packages are not installed when i’m starting the installation. The yunohost-installation.log shows the installation of the bind9 packages, maybe it’s a recommends/suggests dependency ?

Uuuuuh I’m pretty sure it’s not :sweat_smile: But that’s really weird if it got installed during the yunohost install … Do you have the corresponding piece of log ? :s

Sorry, i’m wrong, bind9utils (not bind9) is installed during the yunohost installation.


So by curiosity, if you run

dpkg --get-selections | grep -v deinstall | grep 'bind9 '

(same command but with a space after bind9) does that still shows some results ?

It’s not, the output is empty.

Hm so maybe

dpkg --get-selections | grep -v deinstall | grep 'bind9\s'

should do it ? (\s after bind9 now)

I was going to suggest with 'grep -P ‘bind9\t’ but yes, with ‘\s’ just bind9 is appearing.

Ah yea maybe that also works :sweat_smile:

Well I’ll fix that in the script then ! So that if bind9 is installed previous to the install, the script will ask the user to uninstall it. (I think this situation happens for instance on some OVH machines ?)

Ok, great ! (Almost, in a online .net server)

Fixed it !

Thanks for the feedback !

So, after hours testing it, this is what doesn’t worked for me :

Impossible to install “Searx” because “the user searx doesn’t exist” or nextcloud…
Impossible to install unofficial app for a missing manifest.json file error
However, that’s possible with the community apps list
Not able to update the system

That’s it for now

Hey, thanks a lot for the feedback !

Those are known issue being investigated / fixed

That’s pretty weird :thinking: As asked in your private message, can you re-run the command in command line with --debug and show the output ?

Uh what do you mean by that ? Which command are you using and why doesnt it seem to be able to ?

hey here,

so some context :

  • vm debian 8 fresh install
  • install yunohost with script
  • config yunohost : users and domain
  • install nextcloud, wallabag, shaarli, dokuwiki, gogs
  • create (or upload) data for this apps
  • script for debian update

the only problem I have is a blank page with nextcloud. I already had this pb but I don’t remember how resolv this. And I find nothing in the log …

Good work team.

1 Like

Hey !

Thanks for the feedback !

There’s a fix on the way for nextcloud, but in the meantime you might be able to solve the issue by manually installing php-zip with apt-get install php-zip

It’s not this …
I search …


# yunohost app debug nextcloud
Error: Unknown service 'php5-fpm'

Bonjour @Aleks ,

Je viens de tester rapidement l’installation de YunoHost sur une base Debian Stretch 64 dans une VirtualBox.

bash <(wget -q -O-
Cette commande, en root, est passée sans problème.

  • La post-installation avec s’est déroulée sans problème.
    D’ailleurs, tu peux supprimer ce nom de domaine ASAP :wink:

  • La création de l’utilistateur principal s’est déroulée sans problème.

  • L’installation de Rainloop s’est déroulée sans problème.

  • L’installation de Roundcube a échoué.

Exécution du script « /var/cache/yunohost/from_file/roundcube_ynh-a780644e4278af24de44ad95228c6bf8b6d0f658/scripts/remove »…
roundcube’s script has encountered an error. Its execution was cancelled.
Unable to install dependencies
E: Les paquets doivent être enlevés mais la désinstallation est désactivée.
+ exit 1
+ echo ''
+ ynh_die
+ type -t ynh_clean_setup
+ echo -e '!!\n roundcube'\''s script has encountered an error. Its execution was cancelled.\n!!'
+ set +eu
+ trap '' EXIT
+ '[' 1 -eq 0 ']'
+ local exit_code=1
+ ynh_exit_properly
+ exit 1
+ echo 'Unable to install dependencies'
+ ynh_die 'Unable to install dependencies'
+ sudo apt-get -y -qq --no-remove -o Dpkg::Options::=--force-confdef -o Dpkg::Options::=--force-confold install -f
+ DEBIAN_FRONTEND=noninteractive
+ ynh_apt --no-remove -o Dpkg::Options::=--force-confdef -o Dpkg::Options::=--force-confold install -f
+ ynh_package_install -f
Paramétrage de roundcube-ynh-deps (1.3.3-1) …
Le paquet php-net-ldap3 n’est pas installé.
roundcube-ynh-deps dépend de php-net-ldap3 ; cependant :
Le paquet php-net-ldap2 n’est pas installé.
roundcube-ynh-deps dépend de php-net-ldap2 ; cependant :
Le paquet php-crypt-gpg n’est pas installé.
roundcube-ynh-deps dépend de php-crypt-gpg ; cependant :
Le paquet php-net-socket n’est pas installé.
roundcube-ynh-deps dépend de php-net-socket ; cependant :
Le paquet php-net-smtp n’est pas installé.
roundcube-ynh-deps dépend de php-net-smtp ; cependant :
Le paquet php-patchwork-utf8 n’est pas installé.
roundcube-ynh-deps dépend de php-patchwork-utf8 ; cependant :
Le paquet php-mail-mime n’est pas installé.
roundcube-ynh-deps dépend de php-mail-mime ; cependant :
Le paquet php-auth-sasl n’est pas installé.
roundcube-ynh-deps dépend de php-auth-sasl ; cependant :
dpkg: roundcube-ynh-deps : problèmes de dépendances, mais configuration comme demandé :
Dépaquetage de roundcube-ynh-deps (1.3.3-1) …
Préparation du dépaquetage de …/roundcube-ynh-deps_1.3.3-1_all.deb …
(Lecture de la base de données… 52783 fichiers et répertoires déjà installés.)
Sélection du paquet roundcube-ynh-deps précédemment désélectionné.
+ sudo dpkg --force-depends -i ./roundcube-ynh-deps_1.3.3-1_all.deb
+ equivs-build ./control
+ cd /tmp/tmp.IfxbTCLMqh

  • L’installation de Wallabag2 s’est déroulée sans problème.

  • L’installation de Nextcloud a échoué :

#2 {main}Création du répertoire « /home/nextcloud ».
#1 /var/www/nextcloud/occ(11): require_once(’/var/www/nextcl…’)
#0 /var/www/nextcloud/console.php(99): OC\Console\Application->loadCommands(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
Stack trace:
Exception: Environment not properly prepared. in /var/www/nextcloud/lib/private/Console/Application.php:145
An unhandled exception has been thrown:
Please ask your server administrator to install the module.
PHP module zip not installed.
Nextcloud is not installed - only a limited number of commands are available

J’ai donc installé php-zip

apt install libzip4 php-zip php7.0-zip

L’installation est allée jusqu’au bout malgré la présence de ce message

Nextcloud is not installed - only a limited number of commands are available
Nextcloud was successfully installed

  • L’installation d’un certificate Let’s Encrypt n’est pas allée jusqu’à son terme à cause des limitations de création/renouvellement de certificats. Sinon, tout le reste était a priori bien configuré d’après le message au niveau du panel de l’interface web.



I tested the case #1 on a Raspberry Pi 3, model B, with a newly installed Rasbian.

root@orobas:~# cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION="9 (stretch)"

and I had a minor issue during the installation of Yunohost:

[INFO] Running install_script_dependencies
Reading package lists...
Building dependency tree...
Reading state information...
Package dialog is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'dialog' has no installation candidate
[FAIL] Unable to install dependencies to install script

It was fixed after doing

apt-get update

and re-launching the installtion script with:

bash <(wget -q -O-
1 Like

Hello again,

I had 2 other minor (?) issues, during the post installation step.

Context :
_ Hardware : Raspberry Pi 3, model B with a 32GB SD card.

_ Network : Basic network configuration with static IP

root@orobas:~# ping -c 1
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=54 time=22.2 ms

--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 22.223/22.223/22.223/0.000 ms

_ OS: Newly installed Raspbian (Stretch).

_ Packages: I’ve installed tmux and Yunohost with the given installation script in case #1 (see my previous post).


root@orobas:~# yunohost tools postinstall
Main domain:
New administration password: 
Confirm new administration password: 
Error: [Errno 52] Invalid url (does this site exists ?)

But when I try to join this URL, it seems to work fine:

root@orobas:~# wget
--2018-04-17 21:42:13--
Resolving (, 2a03:7220:8080:5c00::1
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 23 [application/json]
Saving to: ‘domains’

domains                       100%[==============================================>]      23  --.-KB/s    in 0s

2018-04-17 21:42:13 (4.68 MB/s) - ‘domains’ saved [23/23]

The other issue accured during the same command:

Success! The firewall has been reloaded
Error: Unable to retrieve the remote application list yunohost: HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /official.json (Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x7525c9d0>: Failed to establish a new connection: [Errno -2] Name or service not known',))
Warning: Skipping migration 1 change_cert_group_to_sslcert...
Warning: Skipping migration 2 migrate_to_tsig_sha256...
Warning: Skipping migration 3 migrate_to_stretch...
Warning: Skipping migration 4 php5_to_php7_pools...
Synchronizing state of yunohost-firewall.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable yunohost-firewall
Success! The service 'yunohost-firewall' has been enabled
1 Like