Alpha-stage testing for YunoHost 12.0 on Debian Bookworm (but not yet for the Bullseye→Bookworm migration)

Update of Yunohost and Nextcloud went well.
Now, if I disconnect from nextcloud, it disconnect me from Yunohost.
However, if I disconnect from Yunohost, I remain logged in nextcloud.

I couldn’t see any change for Wallabag and Gitea.

Yes, that one is a long-term non-trivial issue, not specific to Bookworm

3 Likes

And for Wallabag and Gitea? Do they need an update of their package to work with the new sso?

Ah, my brain skipped that part, will have a look

You can add auto logout in nextcloud config as a workaround

‘remember_login_cookie_lifetime’ => 1296000, ‘session_lifetime’ => 1800, ‘session_keepalive’ => false, ‘auto_logout’ => true,

See the documentation
https://docs.nextcloud.com/server/19/admin_manual/configuration_server/config_sample_php_parameters.html?highlight=lifetime

1 Like

Hello,
I’m trying the alpha version of YunoHost 12.0, install and config ok ! :+1:

VPN client installation failed but I can’t see anything in logs

How can I find anything usefull for debugging ?

The screenshot was already enough info for that. The error message was obviously crap, I improved it to have more details for being able to debug, but ultimately the issue lies in the VPNclient app and will be implicitly solved when we’ll merge Testing | Packaging v2 + generate config during upgrade + Add hook scripts by alexAubin · Pull Request #117 · YunoHost-Apps/vpnclient_ynh · GitHub

Great news!

I have a brand new Khadas VIM4 board. I installed Armbian through the integrated system (OOWOW).

I’ve failed installing YunoHost.

I tried the default installation command :

root@khadas-vim4:~# curl https://install.yunohost.org | bash
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 23323  100 23323    0     0  54106      0 --:--:-- --:--:-- --:--:-- 54239
[FAIL] YunoHost is only available for the version 11 (Bullseye) of Debian, you are using 'bookworm/sid'.
[INFO] Installation logs are available in /var/log/yunohost-installation_20240209_155029.log

The error is my fault. The Armbian version is not the correct one.

I then tried the following :

root@khadas-vim4:~# curl https://install.yunohost.org/bookworm | bash -s -- -d unstable
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 25036  100 25036    0     0  67651      0 --:--:-- --:--:-- --:--:-- 67848
[FAIL] Please don't try to install YunoHost on an Ubuntu or Linux Mint system ... You need a 'raw' Debian 12 (Bookworm).

This is disappointing. The first error message says I’m using Bookworm but the second error message says I don’t use it.
What’s going on ?

Regards,
Nicolas

You probably are running an Ubuntu version of Armbian. Yes, the first message says you’re running “bookworm/sid”, but that’s just because Ubuntu is based on Debian.

1 Like

Thanks. Any way to get this information from command line ?

I guess cat /etc/os-release shows a full description of the linux distribution you’re running

1 Like

You are right. It identifies as Ubuntu in the file. I’ll change the OS image to a Debian based one.
Thanks a lot for your support.

2 Likes

Great work as always! I’ve updated my Yunohost playground to test 12.0 and everything looks good after some tweaking, apart from email relay support: when trying to set any variable related to email relay, I get this kind of error:

root@dmz:~# yunohost settings set email.smtp.smtp_relay_host -v mail.example.com
========================================
>>>> Email
========================================

# SMTP
Traceback (most recent call last):
  File "/usr/bin/yunohost", line 77, in <module>
    yunohost.cli(
  File "/usr/lib/python3/dist-packages/yunohost/__init__.py", line 41, in cli
    ret = moulinette.cli(
          ^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/moulinette/__init__.py", line 115, in cli
    ).run(args, output_as=output_as, timeout=timeout)
      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/moulinette/interfaces/cli.py", line 501, in run
    ret = self.actionsmap.process(args, timeout=timeout)
          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/moulinette/actionsmap.py", line 567, in process
    return func(**arguments)
           ^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/yunohost/log.py", line 407, in func_wrapper
    result = func(*args, **kwargs)
             ^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/yunohost/settings.py", line 101, in settings_set
    return settings.set(key, value, args, args_file, operation_logger=operation_logger)
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/yunohost/utils/configpanel.py", line 565, in set
    self.form = self._ask(
                ^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/yunohost/utils/configpanel.py", line 856, in _ask
    form = prompt_or_validate_form(
           ^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/yunohost/utils/form.py", line 2053, in prompt_or_validate_form
    if not option.is_visible(context):
           ^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/yunohost/utils/form.py", line 416, in is_visible
    return evaluate_simple_js_expression(self.visible, context=context)
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/yunohost/utils/form.py", line 216, in evaluate_simple_js_expression
    return evaluate_simple_ast(node, context)
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/yunohost/utils/form.py", line 104, in evaluate_simple_ast
    return context[node.id]
           ~~~~~~~^^^^^^^^^
KeyError: 'smtp_relay_enabled'

Finally got the correct armbian version installed.

The installation run smoothly.
But the post installation did not.

I entered a domain, a user name and a password.
I was unable to click on the connexion button. I then clicked on interface utilisateur and entered another domain, name and paswword.
I was then able to click on connexion but got this error :

Any way to reset and re-run post install ?

I run yunohost tools regen-conf through SSH and the error vanished.

But there are still strange things. When modifying configuration, I get warnings about configuration files that are ignored because they have been manually modified (which is not the case).

Linode VPS install

Install good, post install good, diagnosis good, update good, added user good, logging into sso gives username or password is possibly invalid. I don’t know how to get the logs but it is a 401.

POST https://ynh12-test.nohost.me/yunohost/portalapi/login with a response of unable to a authenticate.

https://ynh12-test.nohost.me/
Goes to the portal

Yes, but unable to login in as the request to the api comes back as ‘unable to authenticate’. Well, that is my reading…

Just found the reason.

It doesn’t authenticate because there are no apps installed. The situation where a user has no permissions and an app is installed causes the same error.

Hello =),
Specs: WSL2 - Debian with systemd enabled and dbus installed.

I tried to install my usual apps.

Cannot not click on paperless from catalog

Nextcloud installed and working.
Wordpress installed and working.
Scovie installed and working. (the app don’t have an icon, the portal should display a dummy icon)
xNBTD installed and working. (GitHub - eldertek/xnbtd_ynh: Paquet Yunohost pour xNBTD, application de gestion pour entreprise de livraison.)

I didn’t notice others issues, tested as a usual