[Airsonic] Music media streamer

Airsonic for YunoHost

Integration level
Install airsonic with YunoHost

This package allow you to install airsonic quickly and simply on a YunoHost server.
If you don’t have YunoHost, please see here to know how to install and enjoy it.


Airsonic is a free, web-based media streamer, providing ubiquitous access to your music. Use it to share your music with friends, or to listen to your own music while at work. You can stream to multiple players simultaneously, for instance to one player in your kitchen and another in your living room.

Airsonic is designed to handle very large music collections (hundreds of gigabytes). Although optimized for MP3 streaming, it works for any audio or video format that can stream over HTTP, for instance AAC and OGG. By using transcoder plug-ins, Airsonic supports on-the-fly conversion and streaming of virtually any audio format, including WMA, FLAC, APE, Musepack, WavPack and Shorten.

If you have constrained bandwidth, you may set an upper limit for the bit rate of the music streams. Airsonic will then automatically re sample the music to a suitable bit rate.

In addition to being a streaming media server, Airsonic works very well as a local jukebox. The intuitive web interface, as well as search and index facilities, are optimized for efficient browsing through large media libraries. Airsonic also comes with an integrated Podcast receiver, with many of the same features as you find in iTunes.

Shipped version: 10.6.2


Sreenshot of home page of Airsonic



How to configure this app: by an admin panel.


YunoHost specific features

Supported architectures

  • x86-64b - Build Status
  • ARMv8-A - Build Status

More information on the documentation page:


Developers info

Only if you want to use a testing branch for coding, instead of merging directly into master.
Please do your pull request to the testing branch.

To try the testing branch, please proceed like that.

sudo yunohost app install https://github.com/YunoHost-Apps/airsonic_ynh/tree/testing --debug
sudo yunohost app upgrade airsonic -u https://github.com/YunoHost-Apps/airsonic_ynh/tree/testing --debug

Doesn’t work for me. Nginx gives " 502 Bad Gateway" error

Update: it started to work after I rebooted server.


the installation went well but it might be a big presomption but I tought airsonic will be able to read the music in the shared folder : /home/yunohost.multimedia/share/Music

New version released

  • Upgrade airsonic to 14.0
  • Update nginx conf for bigger uploads: Fix #4
1 Like

Of course theres an update 2 days after I install and hit the road for week. Lol.

1 Like

Installed it on a yunohost on a raspberry.

Upload of music is unfortunately not possible via the gui of airsonic due to write protection.
I then tried to copy music files via sftp, but that doesn’t work either, again due to write protection.

Any hint?

Do you have the same problem as described here?

If not, could you provide more details or step by step instructions to reproduce the issue.

Thanks for your reply,

It’s a different problem: write protection:

If I upload here:

I get:

The same over ftp. I can browse and read via ftp, but not write: “access denied”

Update: Solved the problem by accessing via local IP using sftp.

Update 2: Uploading to Nextcloud in the media folder is the simplest way I found out.

so happy to find Airsonic for Yunohost!
Installed it on a yunohost on a raspberry.
After loging as user defined to be admin (during install), I don’t have access to any admin menus.
Any hint?


I’ve seen this problem before. Can you navigate to https://your_domain.tld/path_to_airsonic/generalSettings.view ?

I have an error:
|Status |403|
|Error |Forbidden|
|Message |Access is denied|

Did you try with your “supposed” admin user? You get the same error with personalSettings.view?

Exactly, I was connected as my “supposed” admin user.

I found a workaround:
After installing Airsonic, I connect to AirSonic using admin/admin:

  1. I change the admin password :wink:
  2. I declare my “supposed” admin user as admin :+1:

Then it’s ok :smiley:

New version released

  • Upgrade to version 6.1

:uk: New testing version available

  • upgrade to version 10.6.2

See end of post 1 to see how to do with testing version

:fr: Nouvelle version “test” disponible

  • mise à niveau vers la version 10.6.2

Voir la fin du post 1 pour savoir comment faire avec la version de test ‘testing’

Still, I cannot upload music in my /home/yunohost.multimedia/share/Music folder due to Permission to create file error.

I created the /home/yunohost.multimedia/ folder with the script coming from https://github.com/YunoHost-Apps/yunohost.multimedia

I think this error could be due to the permissions set in that folder. Now I have these permissions

drwxrwxr-x+ 6 user    root 4096 Jun  8 10:20 user
drwxrwxr-x+ 6 root       root 4096 May 15 17:58 share

I tried to upload my file in /home/user/Multimedia/Share/Music using the interface to send files of airsonic without success. The user is admin for airsonic.

Could it be an error of permissions?

Hey there!
If someone (like me) has problems with music uploaded to the shared media folder, not shown in airsonic.
Got to -> Settings -> Users -> Select User -> Check “Allow access to these media folders” and choose right folder

And which folder do you choose, for example?

There was already the “default” one