Activer gzip dans la configuration Nginx

Mon serveur YunoHost

Matériel: Raspberry Pi à la maison / Brique Internet avec VPN
Version de YunoHost: 11.0.9.14 (stable).
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifiiations particulières sur votre instance ? : non

Description du problème

Bonjour,

Où se trouve le fichier de configuration nginx dans Yunohost ? J’ai un petit blog statique Hugo dans une application my_webapp et j’aimerais profiter de la compression des fichiers statiques pour ce blog, en ajoutant gzip_static on;.

J’imagine qu’il s’agit de ce module : --with-http_gzip_static_module, qui est listé avec nginx -V.

Merci.

Salut ,

Je vais te répondre, mais je te conseille de remplir les informations demandées sur ta configuration lors de la création de ton post si tu veux recevoir de l’aide

Les fichiers nginx se trouvent dans /etc/nginx/conf.d/tonndd/tonndd.conf

Bonne journée

1 Like

Bonsoir,

Merci de ta réponse! J’en ai profité pour ajouter la configuration de ma machine qui héberge mon Yunohost.

Sincèrement,

N’ayant jamais touché à une configuraion nginx je suis un peu perdu. Après être allé dans ``/etc/nginx/conf.d/` je me retrouve avec :

admin@arnauld:/etc/nginx/conf.d $ ls
acme-challenge.conf.inc
security.conf.inc
arnauld.org.conf
ssowat.conf
arnauld.org.d
umami.arnauld.org.d
birdnetpi.arnauld.org.conf
weechat.arnauld.org.conf
birdnetpi.arnauld.org.d
weechat.arnauld.org.d
default.d
yunohost_admin.conf
global.conf
yunohost_admin.conf.inc
isso.arnauld.org.conf
yunohost_api.conf.inc
isso.arnauld.org.d
yunohost_panel.conf.inc
petrolette.arnauld.org.conf
yunohost_sso.conf.inc
petrolette.arnauld.org.d

Quel fichier dois-je éditer ?

Merci.

Celui qui correspond à ton site, tu as du lui donner un nom en installant my_webapp.
Note au passage que lors des mises à jour de my_webapp, il est possible que le fichier soit mis à jour, mais c’est pas sûr, en tous cas c’est à garder en tête dès qu’on fait une modification dans YunoHost.

1 Like

Alors je suis plutôt allé voir du coté etc/nginx/nginx.conf (j’imagine que c’est là, mais je ne suis pas certain) ??

Et il y avait déjà :

Gzip Settings

gzip on;

Du coup je me demande si je dois rajouter gzip_static on;

Tous conseils bienvenus, merci.

Ce qu’à voulut dire mamie c’est en fonction du nom de domaine sur lequel tu dois modifier le nginx.

Ton nginx est installé sur quel domaine ?

Mon nginx est installé sur arnauld.org, domaine pour mon Yunohost. My_webapp dans lequel j’ai mes fichiers statiques (générés avec Hugo) est du même domaine avec /xxx à la fin de l’adresse arnauld org/xxx

Du coup le fichier etc/nginx/nginx.conf me semble être celui à éditer plutôt qu’un des fichiers qui sont dans /etc/nginx/conf.d (voir la liste ci-dessus dans un de mes précédents posts).

Donc c’est ici qu’il faut aller :

etc/nginx/conf.d/arnauld.org.d/my_webapp.conf

Et ajouter gzip_static on;

1 Like

Malheureusement, le contenu .gz n’est pas délivré. J’ai aussi essayé de mettre dans /etc/nginx/nginx.conf l’option gzip_static on; essayé avec gzip_static always; redémarré le service nginx après chaque modification,mais rien.

Toute idée bienvenue.

Oui normalement c’est dans celui la ,

Maintenant gzip static tu l’a mis a quel niveau dans le fichier nginx ?

Voici mon fichier etc/nginx/conf.d/arnauld.org.d/my_webapp.conf :

rewrite ^/blog$ /blog/ permanent;
location /blog/ {

# Path to source
alias /var/www/my_webapp/www/;

# Default indexes and catch-all
index index.html index.php;
try_files $uri $uri/ /blog/index.php?$args;

# Prevent useless logs
location = /blog/favicon.ico {
    log_not_found off;
    access_log off;
}
location = /blog/robots.txt {
    allow all;
    log_not_found off;
    access_log off;
}

# Deny access to hidden files and directories
location ~ ^/blog/(.+/|)\.(?!well-known\/) {
    deny all;
}

# Execute and serve PHP files
location ~ [^/]\.php(/|$) {
    fastcgi_split_path_info ^(.+?\.php)(/.*)$;
    fastcgi_pass unix:/var/run/php/php7.4-fpm-my_webapp.sock;
    fastcgi_index index.php;
    include fastcgi_params;
    fastcgi_param REMOTE_USER $remote_user;
    fastcgi_param PATH_INFO $fastcgi_path_info;
    fastcgi_param SCRIPT_FILENAME $request_filename;
}

# Include SSOWAT user panel.
include conf.d/yunohost_panel.conf.inc;

}

gzip_static on;

Essaie de le placer juste après cette ligne, dans le bloc location de ton site.

Comme ça ? :

rewrite ^/blog$ /blog/ permanent;
location /blog/ {

gzip_static on;
# Path to source
alias /var/www/my_webapp/www/;

Le contenu .gz n’est pas délivré non plus.