Accès Seafile Webdav

Bonjour,

J’essaie en vain de me connecter à mon instance seafile via webdav. Selon les différents clients utilisés (commande davfs sous linux, explorateur de fichiers Caja, appli Synchronize Ultimate sous android…), j’ai différents messages d’erreur peu informatifs (bad gateway, connection closed by peer, etc.)

Webdav est bien activé dans le fichier de conf (seafdav.conf). Les fichiers de logs /var/log/seafile/seafdav.log et /opt/yunohost/seafile/logs/seafdav.log demeurent désespérément vides.

En revanche, dans /var/log/seafile/controller.log j’ai ceci :

pid file /opt/yunohost/seafile/pids/seafdav.pid does not exist
seafdav need restart…
spawn_process: /usr/bin/python2.7 -m wsgidav.server.run_server runfcgi --log-file /opt/yunohost/seafile/logs/seafdav.log --pid /opt/yunohost/seafile/pids/seafdav.pid --port 8082 --host localhost

(ce fichier de log demeure également vide)

Or, quand j’exécute manuellement la commande précédente, j’ai ce message d’erreur :

No module named wsgidav.server.run_server

J’ai tenté un pip2 install wsgidav : l’installation du module s’est fait faite, mais le message d’erreur précédent persiste.

(Parallèlement à cela, j’ai ouvert le port 8082 dans les réglages du firewall (mais était-ce utile ?))

Merci pour votre aide :slight_smile:

C’est normal que ce module n’est pas accessible manuellement car seafile lance ce type de service dans un environnement python virtuel. Installer le module manuellement ne résous en rien le problème…

Non cela n’est pas nécessaire. Je recommande de laisser fermé ce port.

Peut tu essayer éventuellement de relancer tout les services seafile avec la commande suivante:

systemctl stop seafile-server.service 
systemctl start seafile-server.service 

Merci pour tes éclairages :slightly_smiling_face:

J’ai déjà essayé de redémarrer les services seafile. Les commandes s’exécutent sans souci, mais cela ne résout pas mon problème malheureusement. Je viens de réessayer à l’instant.

Avant de creuser la piste d’un souci côté serveur, je souhaiterais m’assurer de deux choses côté client :

  • on est bien d’accord que le port que j’indique côté client est celui renseigné dans seafdav.conf ? (soit 8082 par défaut) (edit : hum non, je viens de piger que ce doit plutôt être 443…)
  • mon instance seafile est installé dans un dossier (https://domaine.tld/seafile) ; je ne suis pas certain de l’adresse du serveur webdav : https://domaine.tld/seafile/seafdav ou https://domaine.tld/seafdav ? (je pense que c’est la première, et de toute façon j’ai essayé les deux formules, mais bon…)

Normalement l’url seafdav c’est https://domain.tld/seafdav/. Le port coté client c’est le standard 443.

Avec les éléments que tu me donnes, j’obtiens une erreur de type 502 :

sudo mount -t davfs -o uid=jln https://domain.fr/seafdav kimsufi/ 
[sudo] Mot de passe de jln : 
Please enter the username to authenticate with server
https://domain.fr/seafdav or hit enter for none.
  Username: julien@domain.fr
Please enter the password to authenticate user julien@domain.fr with server
https://domain.fr/seafdav or hit enter for none.
  Password:  
/sbin/mount.davfs: Mounting failed.
502 Bad Gateway

C’est la même erreur que j’obtiens avec tous les autres clients.

J’ai tout de même une trace de la connexion dans /var/log/nginx/seafdav.access.log :

[02/Nov/2019:12:10:21 +0100] "OPTIONS /seafdav/ HTTP/1.1" 502 166 "-" "davfs2/1.5.5 neon/0.30.2"

et ce message d’erreur dans /var/log/nginx/seafdav.error.log

2019/11/02 12:10:21 [error] 16815#16815: *19860 upstream prematurely closed connection while reading response header from upstream, client: 2a02:8429:8101:dd01:a3d0:6ba3:748a:5b67, server: domain.fr, request: "OPTIONS /seafdav/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:8082", host: "domain.fr"

Addendum : après des recherches sur ce type d’erreur, je retombe sur la question du fichier seafdav.pid qui effectivement n’est pas présent sur mon serveur. Même en relançant le service seafile, il n’est pas recréé.

Je vais bientôt sortir la version 7 du package. Peut être qu’il faudra essayer avec cette version.

1 Like

Merci pour tes réponses sur ce topic et pour la gestion du package :+1:

J’attends la mise à jour et reviendrai ici ensuite :slightly_smiling_face: