Accès impossible depuis le net mais possible depuis téléphone

Configuration de mon YunoHost

Matériel: RPi 3
Accès Internet: ethernet à la maison /
YunoHost version:
yunohost: 3.4.2.4
yunohost-admin: 3.4.2.4
moulinette: 3.4.2.4
ssowat: 3.4.2.4
As tu modifié ton yunohost avec des configuration spécifiques ou bien utilise tu uniquement la web administration et/ou la ligne de commande yunohost ? basique

Description de mon problème

Bonjour tout d’abord merci pour ce magnifiue travail et merci a l’équipe derriere yuno.

Concernant mon soucis :

j’accede a mon yuno sans soucis depuis ma connection chez moi, depuis mon téléphone en 4g aussi.
Par contre depuis des connection internet autre impossible d’y avoir accès…
Impossible pour moi d’avoir accès a la page admin, ou en SSH avec une connection autre que en local ou en données mobile.

dejepsp5.noho.st

Des idées ?

Merci d’avance.

Diag :

"host": "Debian 9.8",
"kernel": "4.14.98-v7+",
"packages": {
    "yunohost": {
        "repo": "stable",
        "version": "3.4.2.4"
    },
    "yunohost-admin": {
        "repo": "stable",
        "version": "3.4.2"
    },
    "moulinette": {
        "repo": "stable",
        "version": "3.4.2"
    },
    "ssowat": {
        "repo": "stable",
        "version": "3.4.2"
    }
},
"backports": [],
"system": {
    "disks": {
        "root": "Mounted on /, 14.6GiB (11.5GiB free)",
        "mmcblk0p1": "Mounted on /boot, 43.2MiB (21.3MiB free)",
        "sda1": "Mounted on /media/stockage, 14.2GiB (14.1GiB free)"
    },
    "memory": {
        "ram": "927.2MiB (548.8MiB free)",
        "swap": "100.0MiB (100.0MiB free)"
    }
},
"nginx": [
    "nginx: the configuration file /etc/nginx/nginx.conf syntax is ok",
    "nginx: configuration file /etc/nginx/nginx.conf test is successful"
],
"services": {
    "glances": "running (enabled)",
    "nslcd": "running (enabled)",
    "metronome": "running (enabled)",
    "postfix": "exited (enabled)",
    "rspamd": "running (enabled)",
    "yunohost-firewall": "exited (enabled)",
    "nginx": "running (enabled)",
    "php7.0-fpm": "running (enabled)",
    "dnsmasq": "running (enabled)",
    "fail2ban": "running (enabled)",
    "yunohost-api": "running (enabled)",
    "mysql": "running (enabled)",
    "avahi-daemon": "running (enabled)",
    "dovecot": "running (enabled)",
    "redis-server": "running (enabled)",
    "slapd": "running (enabled)",
    "ssh": "running (enabled)"
},
"applications": {
    "wallabag2": "Wallabag",
    "opensondage": "OpenSondage",
    "rainloop": "Rainloop",
    "kanboard": "Kanboard",
    "nextcloud": "Nextcloud"
},
"security": {
    "CVE-2017-5754": {
        "name": "meltdown",
        "vulnerable": false
    }
}

}

Mise a jour :

Après essaie sur le telephone de collègues impossible d’accéder a mon serveur aussi.

Je ne peux accéder que en local ou sur mon téléphone en 4g…

Uh et tu as bien routé les ports de ta box …?

Salut, normalement oui mais jai peu etre fait une erreur. En pas chez moi cette semaine et impossible de retrouver mon port d’accès a distance de ma freebox…

Mais ce que je ne m’explique pas cest pourquoi j’y ai accès de mon téléphone et pas d’une connection wifi…

Est-ce que dans ta Freebox, tu as un boitier qui amplifie le signal 4G ? Peut-être tiré par les cheveux comme idée, mais sa pourrais expliquer cela ?

Moi depuis ici, smartphone ou ordi ton lien est inactif. Donc comme dis Aleks, les ports ne doivent pas être bon. Depuis le compagnon freebox, dans pararmètre tu ajoute un bail statique pour l’IP de ton serveur puis tu l’ajoute dans DMZ et sa devrait marché

Alors dmz c’est fait ca jen suis sur peut etre mal quoi que.
Concernant le boîtier femto je n’en ai pas et je suis chez Bouygues sur mon telephone. Donc pas de lien…

Je vais devoir attendre de rentrer chez moi pour refaire ça.
Et je prévoirais de reconfig freebox compagnon

alors
enfin rentré chez moi

redirection de port effectué, DMZ fait

dejepsp5.noho.st

  • Web: 80 vert 443 vert
  • [SSH 22 vert
  • [XMPP:] 5222 vert 5269 vert
  • [Email:]` 25 vert 587 vert 993 vert

et toujours impossible de me connecter en dehors de mon réseau local

Bonsoir,

Alors des fois, avec la mise à jour du firmware des ‘gizmo-box’, et bien la partie routeur gérant le DMZ ne fait pas/plus le boulot attendu … il faut alors passer par des règles NAT de transfert de ports.
J’ai actuellement le souci :frowning:

Exemples :

  • http > port d’arrivé sur la box 80 > port de transfert sur ton réseau local 80 > sur adresse IP locale de ton instance IP_locale_instance_yunohost de type 192.168.x.x
  • https > 443 > 443 > 192.168.x.x
  • SSH > 22 > 22 > 192.168.x.x
  • Etc.

Pour retrouver ton IP locale, il suffit de faire

hostname -I #i majuscule dans un Terminal/Console

Edit
https://yunohost.org/#/isp_box_config_fr
https://ports.yunohost.org
Les ports sont bien ouverts.
Peut-être du hairpinning
https://yunohost.org/#/dns_local_network_fr
Ou encore à force d’essayer tu t’es “auto-banni”
https://yunohost.org/#/fail2ban_fr
https://doc.ubuntu-fr.org/fail2ban#de-bannir_une_ip_de_l_un_de_vos_jails
/Edit

ppr

Bonjour,
Apres moult recherche et manipulation j’ai tout d’abord demander une ipv4 full stack a free car mon ip etait diviser.
Du coup jai recuperer lacces a mes port j’ai passer mes ouvertures de port de tcp a udp et cela a marché.

Prochaine etape le vpn mais cela sera pour un autre post

Merci a tous de votre aide

1 Like