404 or page couldn't be opened (LAN-only setup)

,

Hardware: Old server Rack machine ;-D using a VM
YunoHost version: dunno latest just downloaded
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | √
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : Not yet… :wink:
If yes, please explain: I said NO!

Description of my issue

I try to preform some basic functions. Like opening an app after installing it for instance pi-hole and an cloud app. but everything gives me a 404 :frowning: I tried some.example.nl/app/index.php and such URI’s/URL’s.

NB: you can use paste.yunohost.org to share logs and error messages. You can also directly include error messages using backticks like this :

404

https://paste.yunohost.org/raw/ubekifinup
(Please ignore the port forwarding issues for “outside” want it to be LAN only for testing purposes).

Weeeell yep but that might be precisely the issue …

If you’re in a LAN-only setup, did you for example tweak your /etc/hosts (on your laptop/desktop) such that your domain name resolves to your local IP ? Otherwise the “true” DNS record will point to your global IP, which means your internet router, but if your internet router doesn’t forward the port, there’s no chance that you’ll reach your server …

Hello,

I can reach it with every computer or device locally at least YH itself, not the apps. Also Is there some better instruction on changing the ports? I tried to nano the config but it was empty maybe the topic I flowed is pointing to an older location?

Maybe you can reach it using the local IP, yeah, but not with the domain name (at least not without tweaking your /etc/hosts if you don’t configure port forwarding)

Please no, don’t do this. From my experience, it’s a waste of time to attempt to do this, it won’t work and/or will be extremely painful.

I have to cause that port is already used by another server and it’s a typical Zyxel thing to don’t let users use the same port on different servers dumb ain’t it?
Look…
Schermafbeelding 2020-09-28 om 23.53.28

Going to 192.168.x.x/pihole routes me back to the yuno admin panel…

Oké oké, jeez sorry I didn’t know that you would get angry :worried: :grimacing: :joy: :rofl: :sweat_smile:

Does this make you happy…
Schermafbeelding 2020-09-29 om 00.36.17

1 Like

OMG thanks to you my friend. NOW I CAN FINALY SAY GOODBYE TO MY HOSTS AND BE MY OWN :smiley:

ticket closed (please destroy it due to things) :wink:

1 Like

Not sure what the screenshot is, but glad it works ¯\_(ツ)_/¯

(It seems to be some port forwarding stuff, though I notice port 80 ain’t in the list, maybe that’s the thing you mentioned earlier that you can’t create a rule for it, but beware that might prevent you from installing Let’s Encrypt cert … but anyway the Diagnosis should kind of tell you about it)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.